Pablo Software Solutions Forum Index Pablo Software Solutions

 
 FAQFAQ   SearchSearch   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Unable to get the file list

 
Post new topic   Reply to topic    Pablo Software Solutions Forum Index -> Quick 'n Easy FTP Server
View previous topic :: View next topic  
Author Message
g4danny



Joined: 27 Oct 2005
Posts: 5

PostPosted: Thu Oct 27, 2005 1:20 am    Post subject: Unable to get the file list Reply with quote

Hi,
I have just installed the Q'n'E FTP Server on my Win XP SP2 machine, I set up the router to forward the port 21 for both TCP and UDP and I am testing the FTP access. The results are the following:

Simulating remote access on the same machine that runs the server:
- using IE: connects, shows directory listing
- using Firefox: connects, listing fails (shows home folder as empty)

Actual remote access from Mac OS X environment:
- using IE: connects, no listing
- using Firefox: connects, no listing
- using command line ftp: connects, claims that "Remote system type is UNIX" , 'ls' and 'dir' commands induce
502 Command not implemented
227 Entering Passive Mode (24,15,20,29,235,96)
and and gives no ftp> prompt for a while, then
200 Port command successful
150 Opening ASCII mode data connection for directory list.
and then (with no prompt) nothing happens.
- using the Fetch FTP GUI client: connects, attempt to do listing gives the following message:
'Fetch could not get the file list because there was a timeout trying to establish a passive mode data connection.
A server firewall might be blocking passive mode (PASV) transfers. Ask the server administrator for help, or try unchecking the "Use passive mode transfers (PASV)" box in the General pane of the Preferences.'

Unchecking the above mentioned box, however, did not make any difference.

Either client, despite there's no directory listing, stays connected. Command "new folder" works, but file tranfer "put" does not work: either there's the same timeout message as above or an error message "Unexpected server response" returned.

I would like to know, what is the most likely cause of my problem. I am a newbie in setting up servers and routers, so I am far from blaming the software. I believe it can work for me one day.

Thanks a lot in advance.
Back to top
View user's profile Send private message
g4danny



Joined: 27 Oct 2005
Posts: 5

PostPosted: Thu Oct 27, 2005 4:45 am    Post subject: Progressing Reply with quote

Hi,
only after writing up the post I really looked around and saw two posts adressing the same issue, plus I read the QnE help! Now I have set the server's PASV mode up and forwarded all apropriate ports and am trying again. Please consider this topis as on-hold until I post another progress post!
Thanks.
Daniel

Progress 1: Tried Pablo's FTP Wanderer client running from the same machine that is running the server - SUCCESS! Let me try it from a real remote machine tomorrow, and then, hopefully, we'll be able to close the case.
Daniel
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 13 Apr 2005
Posts: 1470

PostPosted: Thu Oct 27, 2005 7:39 am    Post subject: Reply with quote

My guess is that these issues are all related due to an incorrect passive mode setup. Make sure you've also forwarded the passive port range on your router. Or limit the range to 1 or 2 ports and forward only those on the router to make it easier for you. A common single port for FTP is port 20. Read the help for more info about this.
Back to top
View user's profile Send private message Send e-mail
g4danny



Joined: 27 Oct 2005
Posts: 5

PostPosted: Thu Oct 27, 2005 8:30 pm    Post subject: Reply with quote

Thank you,

unfortunately the remote access still does not work. I am forwarding ports 21 and 1024 to my internal IP, the firewall is set up to let through all traffic of the QnE FTP Server and the QnE is set up to use the port 21 in active and 1024 in passive mode (with the option "Get IP from a remote server" set).

Now it works only from an FTP client or IE running on the same machine with the server, not in a real remote access. Remote console clients still give the same messages as before (see the topic post), i.e. no listing, but successful "new folder" command execution. Remote GUI client (Fetch) does not do the listing in either active (recommends trying the passive mode instead) or passive (recommends trying the active mode instead), but performs the "new folder" command fine again.

I did read help, I did read other posts that sounded like the same problem and I think I did all that I was instructed to do.... Crying or Very sad Can there be any problem like "you have to restart the router and the system after you make changes in settings"? I am down to the basics, really.
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 13 Apr 2005
Posts: 1470

PostPosted: Fri Oct 28, 2005 7:02 am    Post subject: Reply with quote

I can not tell you if you need to restart your router or even if your router is correctly setup. The fact that listing doesn't work, but New Folder does, clearly indicates that passive mode isn't correctly configured, so that the data connection (needed for listing and file transfer) cannot be made.

Because you have already successfully setup the control connection (port 21). Now al you have to do is make the data connection work:

1. Set the passive port range to 20 - 20
2. Select 'Get IP from remote server'
3. Restart the FTP server (just to be sure)
4. Forward port 20 exactly the same as port 21
5. Make sure the router doesn't have a build-in FTP server, which is turned on!
6. Make sure nothing else is using port 20
7. Remote users MUST always use passive mode and ofc ourse also have their ports opened on their firewall.

If it still doesn't work, please give me a snapshot of your FTP server log file.
Back to top
View user's profile Send private message Send e-mail
g4danny



Joined: 27 Oct 2005
Posts: 5

PostPosted: Tue Nov 01, 2005 9:08 am    Post subject: Progressing .... Reply with quote

Hi,
trying a lot of combinations of settings (QnE server, Windows firewall, router) I discovered that the most likely culprit of my trouble is the interaction of QnE connection with Windows firewall (WFW).

When I run the server with WFW turned OFF (i.e. WFW is completely off when starting QnE), I can connect over port 21 (both active or PASV) and have LIST command carried out successfully from FTP Wanderer, Firefox and everything. Once I turn WFW ON, no WFW Exceptions settings of allowed ports or applications let the PASV mode work.

When WFW is ON (ports 21 and 20 are listed as exceptions, QnE FTP Server is listed as "allowed" application):
* FTP Wanderer connects and lists properly only in active mode and only if running on the same machine with the server.
* IE connects and lists properly only if running on the same machine with the server. In other places it gives empty (incorrect) listing.
* Firefox does connects but with empty listing (that is, not connected properly), no matter where it is running.

One thing makes the impression that the guilt is not entirely on Microsoft WFW side: When I start QnE server with WFW ON and then turn WFW OFF, the server remains inaccessible (in the sense of full functionality). I have to stop and start the server again (toolbar buttons, not the whole application) while WFW is OFF to get the functionality I crave. I do not blame solely QnE either, I don't feel expert enough.

I still have not tested the remote access with WFW OFF, I will post an update within one 24 hours. Should it work satisfactorily, though, I still hesitate to run the server machine without a firewall on. Could you tell me, what you think about risks, if the computer is behind a router and has only specific ports (20 and 21 now) forwarded?
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 13 Apr 2005
Posts: 1470

PostPosted: Tue Nov 01, 2005 10:15 am    Post subject: Reply with quote

- WFW must be configure to forward all active ports to QnE FTP server.
There are no known incompatabilities with WFW, so if you it doesn't work for you, you might want to install a clean copy of XP and simply accepts the default settings once you run QnE FTP server for the first time.
- If IE doesn't show a listing, disable passive mode for local connections and enable it for remote connections (Tools->Internet Options->Advanced)
- The same is true for FireFox although I have no idea how to enable/disable passive mode in FireFox.

If you not sure if QnE server is the cause of your problems, simply install another FTP server and you will have the same problems...
Back to top
View user's profile Send private message Send e-mail
g4danny



Joined: 27 Oct 2005
Posts: 5

PostPosted: Tue Nov 01, 2005 4:21 pm    Post subject: Trial confirmed WFW a culprit Reply with quote

Hi,
thank you for your shared experience. I have just verified that remote access in both modes works O.K., when the WFW is completely down.

There is little need to verify with other server softwares. I have other servers installed and none of them worked to date - as well as I never turned WFW off completely. I will try the other pieces of software now without WFW and see, but all in all, one working server is enough. NO reason it shouldn't be QnE, is there?

I meant no offense with saying "QnE and WFW seem to share the guilt". The fact remains that my WinXP installtion is 11 months old and the simple acceptance of the default settings once QnE runs for the first time, did not work. I may try a fresh Win instal or maybe I will turn to another firewall application.

Once again, thank you for help.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Pablo Software Solutions Forum Index -> Quick 'n Easy FTP Server All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


SwiftBlue Theme created by BitByBit
Powered by phpBB © 2001, 2002 phpBB Group