Pablo Software Solutions Forum Index Pablo Software Solutions

 
 FAQFAQ   SearchSearch   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Mail stuck in queue

 
Post new topic   Reply to topic    Pablo Software Solutions Forum Index -> Quick 'n Easy Mail Server
View previous topic :: View next topic  
Author Message
Cold Evil



Joined: 19 Nov 2008
Posts: 11

PostPosted: Fri Apr 03, 2009 5:46 pm    Post subject: Mail stuck in queue Reply with quote

Hello,
I have some problems whit all the mails.
Every mail set to my server get stocked in the queue directory.

I have done the things described in this post but it didn’t work.

Here are the Configurations:

Domains:
- Domain
-- contact

Relay:
- General
-- Replay messages (X)
-- Server Hostname: coldevil.com
-- DNS Server: coldevil.com
-- Max. recipients 0

User Accounts:
-User Accounts
--Username: contact
--Password: ************
--Fullname:contact@coldevil.com

Whats wrong? Sad
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 13 Apr 2005
Posts: 1470

PostPosted: Fri Apr 03, 2009 7:01 pm    Post subject: Reply with quote

Ate you sure the DNS server value is correct?
Did you test it?
Back to top
View user's profile Send private message Send e-mail
Cold Evil



Joined: 19 Nov 2008
Posts: 11

PostPosted: Mon Apr 06, 2009 11:31 am    Post subject: Reply with quote

Ok were do I check this?

I can receive mails and they get stock in the Q dir.
When I send mail they don’t leave the Q list instead they joust laying there and waiting for nothing.
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 13 Apr 2005
Posts: 1470

PostPosted: Mon Apr 06, 2009 7:07 pm    Post subject: Reply with quote

'coldevil.com' does not look like a valid DNS server Confused Are you really sure that is ok?
Did you read the help?
Did you click the 'Test' button and enter an email address?
Do you get a response from the DNS server?
Back to top
View user's profile Send private message Send e-mail
Cold Evil



Joined: 19 Nov 2008
Posts: 11

PostPosted: Mon Apr 06, 2009 7:35 pm    Post subject: Reply with quote

ah i get it ^^
but the dns didnt work Sad

Is this right?
http://dns.loopia.se/XDynDNSServer/XDynDNS.php
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 13 Apr 2005
Posts: 1470

PostPosted: Mon Apr 06, 2009 8:23 pm    Post subject: Reply with quote

You must enter the IP address or hostname of a DNS server.
Your ISP usually provides you access to a DNS server or you can search on the Internet for an open DNS server.
Back to top
View user's profile Send private message Send e-mail
Cold Evil



Joined: 19 Nov 2008
Posts: 11

PostPosted: Mon Apr 06, 2009 9:05 pm    Post subject: Reply with quote

Loopia provide me with a DNS address ”coldevil.com”
And the Server address to the Loopia server is “http://dns.loopia.se/XDynDNSServer/XDynDNS.php”
When I use the Server address the email server tells me “unable to resolve”

What have I done wrong? Crying or Very sad

------------------------------------------------
It looks like this now:

Domains:
- Domain
-- contact

Relay:
- General
-- Replay messages (X)
-- Server Hostname: coldevil.com
-- DNS Server: http://dns.loopia.se/XDynDNSServer/XDynDNS.php
-- Max. recipients 0

User Accounts:
-User Accounts
--Username: contact
--Password: ************
--Fullname: contact@coldevil.com
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 13 Apr 2005
Posts: 1470

PostPosted: Tue Apr 07, 2009 6:31 am    Post subject: Reply with quote

A DNS address is not the same as a DNS server.
Please contact your ISP and ask for the primary DNS server.

From the help file:

Quote:
The domain name system (DNS) enables each machine connected on the Internet to be recognized by a domain name. Every computer on the Internet has a unique IP (Internet protocol) address which consists of a string of numbers. Since the IP addresses can be difficult to remember, the DNS allows a familiar string of letters (the "domain name") to be used instead of the IP address. So instead of typing the IP address' you can type, for example, "www.microsoft.com."

Quick 'n Easy Mail Server needs a valid DNS server address to request to matching server for a specific email address, so it can deliver the messages for this address to the right mail server. Usually your ISP provides a DNS server IP address which you can use for this purpose.
Back to top
View user's profile Send private message Send e-mail
Cold Evil



Joined: 19 Nov 2008
Posts: 11

PostPosted: Tue Apr 07, 2009 11:38 am    Post subject: Reply with quote

Ok I have found the DNS Server now 195.54.122.204 or 195.54.122.200

Quote:
The company support page, and i translated the text here:

What are Bredbandsbolagets DNS-servers?
195.54.122.200 and 195.54.122.204.


--------------
Now It look like this:

Domains:
- Domain
-- contact

Relay:
- General
-- Replay messages (X)
-- Server Hostname: coldevil.com
-- DNS Server: 195.54.122.204
-- Max. recipients 0

User Accounts:
-User Accounts
--Username: contact
--Password: ************
--Fullname: contact@coldevil.com

--------------

But when I send and receive mails they get placed in the badmail dir.

--------------
Log Message:

Code:
12:31:20.312  [2896] <SMTP> Client connected from 84.218.17.234
12:31:20.312  [2896] <SMTP> 220 Quick 'n Easy Mail Server
12:31:20.359  [2896] <SMTP> HELO coldevil
12:31:20.359  [2896] <SMTP> 250 OK
12:31:20.421  [2896] <SMTP> MAIL FROM: <contact@coldevil.com>
12:31:20.421  [2896] <SMTP> 250 OK
12:31:20.484  [2896] <SMTP> RCPT TO: <cold.evil@coldevil.com>
12:31:20.484  [2896] <SMTP> Forwarding email to: <cold.evil@coldevil.com>
12:31:20.484  [2896] <SMTP> 250 OK
12:31:20.546  [2896] <SMTP> DATA
12:31:20.546  [2896] <SMTP> 354 End with <CRLF>.<CRLF>
12:31:20.640  [1504] <SMTP> Incoming message: 1688129C8A3E411F81D4BB11CD241844.eml
12:31:20.640  [1504] <SMTP> Copying message to: S:\MAIL-Dir\queue\
12:31:20.640  [2896] <SMTP> 250 OK: Queued as: 1688129C8A3E411F81D4BB11CD241844
12:31:20.640  [1784] <RELAY> Detected new messages in queue.
12:31:20.640  [1784] <RELAY> Checking file: 1688129C8A3E411F81D4BB11CD241844.eml
12:31:20.703  [2896] <SMTP> QUIT
12:31:20.703  [2896] <SMTP> 221 Bye
12:31:20.703  [2896] <SMTP> Client disconnected from 84.218.17.234
12:31:21.671  [1784] <RELAY> DNS Lookup for 'coldevil.com' failed!
12:31:21.671  [1784] <RELAY> Copying message to: S:\MAIL-Dir\badmail\
12:31:21.671  [1784] <RELAY> Finished delivery of mail.
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 13 Apr 2005
Posts: 1470

PostPosted: Tue Apr 07, 2009 9:03 pm    Post subject: Reply with quote

'coldevil.com' doesn't seem to have a MX record for mail!

Please check out this tool:
http://www.mxtoolbox.com/index.aspx
and you will learn that coldevil.com doesn't work there either, so this is not directly related to the mail server.

Please contact your domain provider and update the MX record so that it points to your computer, the one where your mail server is running on.
Back to top
View user's profile Send private message Send e-mail
Cold Evil



Joined: 19 Nov 2008
Posts: 11

PostPosted: Wed Apr 08, 2009 7:59 pm    Post subject: Reply with quote

Ok the MX record is fixed and the DNS is fixed.
But the e-mails now get stock in the queue and the program is resending them.

Log:
Code:
20:53:09.796  [2688] <SMTP> Client connected from 84.218.17.234
20:53:09.796  [2688] <SMTP> 220 Quick 'n Easy Mail Server
20:53:09.843  [2688] <SMTP> HELO coldevil
20:53:09.843  [2688] <SMTP> 250 OK
20:53:09.906  [2688] <SMTP> MAIL FROM: <contact@coldevil.com>
20:53:09.906  [2688] <SMTP> 250 OK
20:53:09.968  [2688] <SMTP> RCPT TO: <cold.evil@coldevil.com>
20:53:09.968  [2688] <SMTP> Forwarding email to: <cold.evil@coldevil.com>
20:53:09.968  [2688] <SMTP> 250 OK
20:53:10.031  [2688] <SMTP> DATA
20:53:10.031  [2688] <SMTP> 354 End with <CRLF>.<CRLF>
20:53:10.093  [1504] <SMTP> Incoming message: 5B6563FB6EE04DFEBE8C722911128017.eml
20:53:10.093  [1504] <SMTP> Copying message to: S:\MAIL-Dir\queue\
20:53:10.093  [2688] <SMTP> 250 OK: Queued as: 5B6563FB6EE04DFEBE8C722911128017
20:53:10.093  [1784] <RELAY> Detected new messages in queue.
20:53:10.093  [1784] <RELAY> Checking file: 5B6563FB6EE04DFEBE8C722911128017.eml
20:53:10.156  [2688] <SMTP> QUIT
20:53:10.156  [2688] <SMTP> 221 Bye
20:53:10.156  [2688] <SMTP> Client disconnected from 84.218.17.234
20:53:11.093  [1784] <RELAY> Delivering email to '<cold.evil@coldevil.com>' (coldevil.com)
20:53:12.593  [772] <SMTP> Client connected from 84.218.17.234
20:53:12.593  [772] <SMTP> 220 Quick 'n Easy Mail Server
20:53:12.609  [1784] <RELAY> 220 Quick 'n Easy Mail Server
20:53:12.609  [1784] <RELAY> HELO coldevil.com
20:53:12.640  [772] <SMTP> HELO coldevil.com
20:53:12.640  [772] <SMTP> 250 OK
20:53:12.671  [1784] <RELAY> 250 OK
20:53:12.671  [1784] <RELAY> MAIL FROM: <contact@coldevil.com>
20:53:12.703  [772] <SMTP> MAIL FROM: <contact@coldevil.com>
20:53:12.703  [772] <SMTP> 250 OK
20:53:12.734  [1784] <RELAY> 250 OK
20:53:12.734  [1784] <RELAY> RCPT TO: <cold.evil@coldevil.com>
20:53:12.765  [772] <SMTP> RCPT TO: <cold.evil@coldevil.com>
20:53:12.765  [772] <SMTP> Forwarding email to: <cold.evil@coldevil.com>
20:53:12.765  [772] <SMTP> 250 OK
20:53:12.796  [1784] <RELAY> 250 OK
20:53:12.812  [1784] <RELAY> DATA
20:53:12.828  [772] <SMTP> DATA
20:53:12.828  [772] <SMTP> 354 End with <CRLF>.<CRLF>
20:53:12.859  [1784] <RELAY> 354 End with <CRLF>.<CRLF>
20:53:12.859  [1504] <SMTP> Incoming message: 7F0B35BB905C4F2C9661A37FAF731641.eml
20:53:12.859  [1504] <SMTP> Copying message to: S:\MAIL-Dir\queue\
20:53:12.875  [772] <SMTP> 250 OK: Queued as: 7F0B35BB905C4F2C9661A37FAF731641
20:53:12.890  [1784] <RELAY> 250 OK: Queued as: 7F0B35BB905C4F2C9661A37FAF731641
20:53:12.890  [1784] <RELAY> QUIT
20:53:12.921  [772] <SMTP> QUIT
20:53:12.921  [772] <SMTP> 221 Bye
20:53:12.921  [772] <SMTP> Client disconnected from 84.218.17.234
20:53:12.953  [1784] <RELAY> 221 Bye
20:53:12.953  [1784] <RELAY> Disconnected from SMTP server.
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 13 Apr 2005
Posts: 1470

PostPosted: Thu Apr 09, 2009 6:53 am    Post subject: Reply with quote

That is probably because you are sending the mail to yourself?
Did you add the coldevil.com to your domains in the 'Domains' tab?
Back to top
View user's profile Send private message Send e-mail
Cold Evil



Joined: 19 Nov 2008
Posts: 11

PostPosted: Thu Apr 09, 2009 12:29 pm    Post subject: Reply with quote

No I didn’t.
Should I do that?

EDIT: Did. Now it works! Very Happy
Many Thx! Very Happy
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Pablo Software Solutions Forum Index -> Quick 'n Easy Mail Server All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


SwiftBlue Theme created by BitByBit
Powered by phpBB © 2001, 2002 phpBB Group