Pablo Software Solutions Forum Index Pablo Software Solutions

 
 FAQFAQ   SearchSearch   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

WWB and PHP

 
Post new topic   Reply to topic    Pablo Software Solutions Forum Index -> Quick 'n Easy Web Server
View previous topic :: View next topic  
Author Message
Mipani



Joined: 21 May 2008
Posts: 13
Location: Vlaardingen - Netherlands

PostPosted: Wed Oct 29, 2008 10:45 pm    Post subject: WWB and PHP Reply with quote

Co'z of errors using installed all PHP5-extensions.
Now the PHP extensions wont work anymore.
On server a php-cgi error appears saying :
Instruction 0x01f71085 pointstomemory on 0x00000000 read error.
In the mean time userside nothing happens. When clickedon OK at the server, at the userside (explorer) gives a lot of lines....
a few :
Quote:
in Unknown on line 0 PHP Warning: PHP Startup: Unable to load dynamic library 'C:\WebServer\php\ext\php_ingres2.dll' - Kan opgegeven module niet vinden. in Unknown on line 0 PHP Warning: PHP Startup: Unable to load dynamic library 'C:\WebServer\php\ext\php_maxdb.dll' - Kan opgegeven module niet vinden. in Unknown on line 0 PHP Warning: PHP Startup: Unable to load dynamic library 'C:\WebServer\php\ext\php_mcve.dll' ..........

Checked files and are there, and not read only.
php.ini is pointing in to the right map....

Can anyone tell me what i'm doing wrong ???

testsite :
[url]http:www.jornveenendaal.nl[/url] and ----> Nieuwtjes or ----> Kletsplek.
Both parts use WWB extensions like guestbook etc.
When testing out there beware i have to click away the error before the errors appear on your screen... (we live in NL)



Thx in advance
Jos (Team Mipani)
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 13 Apr 2005
Posts: 1472

PostPosted: Thu Oct 30, 2008 5:52 pm    Post subject: Reply with quote

Please note that this error is not directly related to the server.
Your PHP conifguration seems to be wrong based on the error message.
Did you configure PHP to load these modules?
Back to top
View user's profile Send private message Send e-mail
Mipani



Joined: 21 May 2008
Posts: 13
Location: Vlaardingen - Netherlands

PostPosted: Thu Oct 30, 2008 7:04 pm    Post subject: Reply with quote

I've disabled QEW and uninstalled PHP.
And installed UsbWebserver, site ran perfectly. So it had to be in the PHP setup.
I copied the php modulesand ext. to QEW adjusted php.ini and "wow" it works almost ok.
Now with the "newswriter" extension of WWB , reaction is quite slow and
at the bottom text it shows
Quote:
Error in my_thread_global_end(): 1 threads didn't exit

So main problem is/was the php setup.
Hope you can be a bit of help with this Pablo. Co'z we are very happy with QEW next to our Linux webservers.
QEW works great next to our Webshop extension (made with Clarion 4GL),
so that will/can be released soon.
Many thx
Jos
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 13 Apr 2005
Posts: 1472

PostPosted: Fri Oct 31, 2008 7:43 am    Post subject: Reply with quote

QnE Web Server does not require any special setup for PHP.
It simply executes the page through CGI and when the PHP interpreter is done it returns the results to the server.
The PHP error indicates that you did not configure those dlls in the php.ini file or your path setting are not valid.

Note that all PHP errors you see in the browser are directly forwarded from the PHP interpreter, QnE Wbe Server does not generate these errors.
Back to top
View user's profile Send private message Send e-mail
Mipani



Joined: 21 May 2008
Posts: 13
Location: Vlaardingen - Netherlands

PostPosted: Fri Oct 31, 2008 8:46 am    Post subject: Reply with quote

Yep i know,
sorry for asking.
Jos
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Pablo Software Solutions Forum Index -> Quick 'n Easy Web Server All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


SwiftBlue Theme created by BitByBit
Powered by phpBB © 2001, 2002 phpBB Group