Forwarding order

Issues related to Quick 'n Easy Mail Server.
Post Reply
JohnHace
Posts: 3
Joined: Sun Jan 30, 2011 10:48 pm

Forwarding order

Post by JohnHace » Tue Feb 01, 2011 12:48 am

Pablo,

I get a lot of spam on one of my domains (call it domain1.com). I have another domain (call it domain2.com) with less spam. So, I forward *@domain1.com to myusername@pobox.com because they do a good job of filtering spam. Then, I forward the non-spam results to Me@domain2.com.

Now I'm getting more spam on domain2.com. I'd like to forward everything from domain2.com except me@domain2.com to pobox.com.

Is there a way to do this?

Thanks,

John
admin
Site Admin
Posts: 1470
Joined: Wed Apr 13, 2005 9:16 pm

Post by admin » Tue Feb 01, 2011 8:06 pm

I'm sorry but I don' think this is possible (although I didn't try it myself).
JohnHace
Posts: 3
Joined: Sun Jan 30, 2011 10:48 pm

Post by JohnHace » Tue Feb 01, 2011 10:20 pm

Okay. But now I have a bigger problem.

I found that none of my mail is getting forwarded to pobox.com unless I uncheck "Authentication required for non-local recipients."

As I understand it, this would create an open relay and open it to spam.

Is there a way around this?
admin
Site Admin
Posts: 1470
Joined: Wed Apr 13, 2005 9:16 pm

Post by admin » Thu Feb 03, 2011 8:21 am

The option "Authentication required for non-local recipients." does not have any effect on forwarding.
What information is in the log file?
JohnHace
Posts: 3
Joined: Sun Jan 30, 2011 10:48 pm

Post by JohnHace » Thu Feb 03, 2011 4:14 pm

I'm sorry. I think I misspoke.

Let me try to explain again. In my current mailserver, I forward everything in domain1 (*@domain1) to myname@pobox.com. Then I set the pobox account to forward (after blocking spam) the good email to john@domain2.com.

When I try this with QnE, I guess the mail is forwarded to pobox, but nothing is coming back to me unless I turn off authentication for non-local. Then the pobox mail comes through, but I worry about the open relay.

BTW, my old mail server did not have this setting. It required me to login within the last 10 minutes in order to allow me to send mail.

I hope this is clearer than before.
admin
Site Admin
Posts: 1470
Joined: Wed Apr 13, 2005 9:16 pm

Post by admin » Thu Feb 03, 2011 11:04 pm

I think I have to know your extact configuration to understand what you are doing.

If you relay email then there is no authentication, because the remote server will not know the username/password.

The authentication is only used for sending email, not relaying.
Post Reply