When goes mail from queue to the correct mailbox.....

Issues related to Quick 'n Easy Mail Server.
Post Reply
Mipani
Posts: 13
Joined: Wed May 21, 2008 10:51 pm
Location: Vlaardingen - Netherlands

When goes mail from queue to the correct mailbox.....

Post by Mipani » Wed Oct 08, 2008 12:06 pm

I've set up the mailserver.
Situation :
two domains : mail.jornveenendaal.nl and mail.jorrianveenendaal.nl
two mailboxes jorn@jornveenendaal.nl and jorrian@jorrianveenendaal.nl
In the configuration no relay is set.
Messages are comming in, but they stay in the folder queue, i was expecting them to be put in de foldername jorn@jornveenendaal.nl (accountname) or jorrian@jorrianveenendaal.nl
What am i doing wrong ....... ?

So there are multiple domains and multiple users per domain.

BTW i'm using QnWebserver also and works perfectly.

thanks in advance
admin
Site Admin
Posts: 1470
Joined: Wed Apr 13, 2005 9:16 pm

Post by admin » Wed Oct 08, 2008 4:18 pm

Maybe you did not setup the domains correctly?
What is your configureation?
What information is in the log file?
Mipani
Posts: 13
Joined: Wed May 21, 2008 10:51 pm
Location: Vlaardingen - Netherlands

Post by Mipani » Wed Oct 08, 2008 4:49 pm

Both domains are hosted by QnWebServer.
Websites work properly incl. PHP (w/o the mail ext)

The struct :
\webserver (programs)
- - Ftp
- - Web
- - Mail
- - php

\websites
- - jornveenendaal.nl
- - jorrianveenendaal.nl
- - mailboxes
- - - admin
- - - badmail
- - - drop
- - - jorn@jornveenendaal.nl (created by mailprog/user))
- - - jorrian@jorrianveenendaal.nl (created by mailprog/user)
- - - queue

In the mailserver :
Domains :
mail.jornveenendaal.nl
mail.jorrianveenendaal.nl
Relay:
mail.chello.nl
dns: 213.46.255.2
max. 5
Pre-Def DNS:
jornveenendaal.nl -> mail.jornveenendaal.nl

Server LOG :
Client connected from 213.46.255.22
220 Quick 'n Easy Mail Server
HELO viefep14-int.chello.at
250 OK
MAIL FROM:<jos@catersoft.nl>
250 OK
RCPT TO:<jorrian@jorrianveenendaal.nl>
Forwarding email to: <jorrian@jorrianveenendaal.nl>
250 OK
DATA
354 End with <CRLF>.<CRLF>
Incoming message: 5F9409BDAFEE4C83B3A124B25AFA4269.eml
Copying message to: C:\websites\mailboxes\queue\
250 OK: Queued as: 5F9409BDAFEE4C83B3A124B25AFA4269
QUIT
221 Bye
Client disconnected from 213.46.255.22


After this point, the server won't stop and hangs.
Again started, Relay is running and start with:
<RELAY> Checking file : MN.... etc wich is in the map Queue !
Stopping the server gives same result, it hangs.

As logic when emptied the queue map, it works normal and server can be stopped.
POP service works ok, no login errors.
But the messages stays in the queue map.....

I was expecting that the msg would be moved to the folder named as the existing user (jorrian@jorrianveenendaal)

If needed or help i can use crossloop or Radmin(famatech)
I hope this is enough info for you to give me a light :wink:

Pablo, as usual many thx in advance and always at the speed of light.
admin
Site Admin
Posts: 1470
Joined: Wed Apr 13, 2005 9:16 pm

Post by admin » Wed Oct 08, 2008 8:31 pm

Please note that the users should not have the domain name in them.
So instead of
'jorn@jornveenendaal.nl'
please only use
'jorn'

The same thing goes for 'jorrian'.

Also the domain should be entered as
'jornveenendaal.nl' instead of 'mail.jornveenendaal.nl'
Mipani
Posts: 13
Joined: Wed May 21, 2008 10:51 pm
Location: Vlaardingen - Netherlands

Post by Mipani » Wed Oct 08, 2008 9:42 pm

Ok, done that.
But mails are now collected in the map admin .....
still not in the map according to the map "jorn" for instance.
so i'm still missing a link/point i guess......

regards
Jos
Mipani
Posts: 13
Joined: Wed May 21, 2008 10:51 pm
Location: Vlaardingen - Netherlands

Post by Mipani » Wed Oct 08, 2008 9:51 pm

And going thru the map structure,
when i changed the user name, the map wasn't changed.
when changed to the same name as in the program, it worked
Maybe weird from me to expect when the username was changed als the mapname was changed.

One question i still have running around......
Am i correct that filtering and moving the MSG to the user, is QnEMailserver using the name what is put just before the @ sign ???

Thanks for your very quick replies.
Jos
admin
Site Admin
Posts: 1470
Joined: Wed Apr 13, 2005 9:16 pm

Post by admin » Thu Oct 09, 2008 6:43 am

Yes the name before the '@' is the username.
Post Reply