
 
 
 
 
Thanks for choosing WYSIWYG Web Builder! 
In this section we will give a short introduction to Web Builder so you can start building your web site in 
(almost) no time. 
 
Please select one of the topics below. 
 
• An introduction to the basic functionality of WYSIWYG Web Builder 

• Introduction to creating web pages 

• Set page properties 

• Setup guide borders, rulers and grid 

• Adding text to a web page 

• Adding an image to a web page 

• Adding other elements to a web page 

• Adding custom HTML or Javascript to a web page 
• Linking your pages together (Creating Hyperlinks) 

• Saving your web site 

• Preview a page in your Browser 

• Publishing your web pages 

• Adding a Navigation Bar to your web site 

• Adding a Menu Bar to your web site 

• Using templates 

• Importing an existing HTML page in to Web Builder 

• Creating forms 

• Create an Inline Frame 
• Change the color or style of a hyperlink 

• How to use embedded pages 

• What's next? 
 
 



An introduction to the basic functionality of Web Builder 
 
WYSIWYG Web Builder is a Web site building tool that helps you design and build full-featured Web sites 
without having to learn HTML. When you startup Web Builder the main screen will look something like this: 
 

 
 
Standard Tools 
With the 'Standard Tools' toolbar you can execute basic commands like  
Create a new web site, Open an existing web site, Save, Cut, Copy, Paste, Undo, Redo. 

 
 
It also contains icons to insert or edit hyperlinks (9th icon from the left) or add special characters when 
you're in text edit mode. The last two icons are for previewing and publishing. More about that later. 
 
Toolbox 
The toolbox can be used to add new objects to your web pages. To insert a new object, select one of the 
available items and draw a box to indicate the position of the object. The new object will now be inserted to 
the page. Another way to add objects to your page is by simply dragging them out of the toolbox onto the 
workspace. 
 
Tabs 
When you have opened multiple pages you can used the tabs to switch between the pages. To close the 
active page press the small 'x' in the upper right corner of the tabs strip. 
 
Workspace 
The center of the screen is the workspace, where you can drag and drop objects from the toolbox. 
 
Formatting Tools 
The formatting tools are only active when you are in text edit mode. 
To insert text simply drag the text icon on the workspace. A new object with the text "Double click to edit' 
will be displayed on the page. To switch to text edit mode double click this text and the formatting tools will 
become active. For some of the tools you needs to highlight the text before they can be used (just like in a 
regular text editor). 
 



Site Manager 
The Site Manager can be used to manage the structure of your web site.  

The Site Manager has its own toolbar to add, edit, clone or remove 
pages. There's also a button to open the properties of the selected 
page. 
 
In the picture on the left you see an example of a web site structure. 
The filename of this example web site is called 'mywebsite.wbs', this 
name is always displayed at the root of web site tree. 
The root can have one of more pages and each page can also have 
sub pages. 
 
Web sites always have a home page which is often called index, so 
for this reason Web builder automatically adds this page to each new 
project. 
The names of the items (pages) in the site tree are the actual file 
names of the target HTML files, so if you named a page 'index' is will 
publish as index.html. 

 
Add a new page 
Select the position where you want to insert the page, for example select the root (the top level item) to 
insert the page to the first level. Click the first button on the toolbar (New Page).  
To insert a new page as child of an existing page, first select the parent and click 'New Page' 
 
Open an existing page 
Select the item (page name) your want to edit and Click the second button (from the left) on the toolbar 
(Edit Page). 
 
Clone an existing page 
To make an exact copy of an existing page, select the item (page name) you want to clone and click the 
third button (from the left) on the toolbar to insert a copy of that page. 
 
Remove a page 
Select the item (page name) you want to remove and click the remove button on the toolbar or press the 
Delete key on the keyboard. Note: You can not remove the last page in your web site. 
 
Rename a page 
Select the item (page name) and press F2 to enter the new name.  
When you've linked to the page you are renaming (from any page within the web site), Web Builder 
automatically updates all the links for you, so you don't have to redo all the internal links. 
 
Arrange Items 
You can arrange items by using drag and drop, select the item and drag it to the position where you want to 
move it to or you can use the context menu (right click) to move the items to another position. 
 
For more information about the Site Manager please read the help file 
 
Introduction to creating web pages 
 
Are you thinking about creating Web pages? This section will outline some important considerations. 
 
Plan Web Pages 
Planning is essential for creating a Web site, whether your site consists of one page or many. 
Decide what you want to accomplish with your Web pages. Decide on a main topic or theme for your Web 
pages. 
 
Gather Information 
Collect the information you want to include on your Web pages, such as text, images etc. 
 
Organize information 
Divide the information you gathered into sections. Each section should be a seperate Web page. 
 
Home Page 
The home page is the main page in a Web site. The home page is usually the first page people see when 
they visit a website. Always include a brief summary of your Web pages on the home page. 
Your home page should include a table of contents that lists the information contained in your web site. 



You should include links that allow readers to quickly access information of interest. 
Web Builders includes several tools to easily create a table of contents like the navigationbar, menubar or 
the go menu. Read more. 
 
Tips 
1. Study other web sites. 
Before you start creating your Web Pages take a close look at some of your favorite web sites. Determine 
what you like about them and conmsider how you can use these ideas on your pages. 
2. Put important information first 
Always display the most important information at the top of each page. Some users will not scroll through a 
web page to read all the information. 
3. Transfer speed 
When creating your pages, try to keep the file size of the pages and images as small as possible. This will 
speed up the display of your web pages by reducing the time it takes for the information to transfer from the 
server to the browser. Resizing image in Web Builder does not make them smaller in size, so use your 
favorite image editor to resizing the image to the correct size. 
4. Test your web site in different browsers.  
Sometimes when a page looks good in one browser it might not be displayed the same in other browser. 
 
Set Page Properties 
The first thing you probably want to do is set some general page options. Select View->Page Properties 
from the menu to show the Page Propeties window. Here you can specify things like page title, background 
image/color, text colors and the page dimensions. 
 
General 

 
 
Title This title will be displayed in the title bar of the browser's window. 

Button Name This name will be used for the item names in navigationbars and menubars 
when 'Synchronize with Site Manager' is enabled. 

Default Font/Size Specifies the default font style and size that will be used for text you enter in 
the page. 

Page Width and Height Specify the workspace width and height of the page. 

File extension Normally your web page will be published using the .html extension. In some 
cases it might be necessary to specify another extension like .php of .asp in 
case your page uses PHP os ASP. 

Character Set The character set tells the browser how to interpret and display the 
characters on your webpage. Depending on the language of the text on the 
page it might be necessary to force the browser to another character set. 

Center in browser Enabling this option will center the published page in the browser window. 

Don't Publish this page Enable this option if you don't want this page to be published if your select 
Publish Entire Web Site. 
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Background
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Background Image Specifies the optional background image. 

Background Color Specifies the color of the background 

Link Colors Set default colors of hyperlinks. 
Sound If you want to play a background sound when your page is displayed in the 

browser you can specify a background sound. 

 
Meta Tags

 
 
 
 

Author The author meta tag is used to indicate who the author of the web page is. 

Keywords The keyword meta tag can be important when it comes to some search 
engines.  

Description The description meta tag can be important when it comes to some search 
engines 

Generator Typically the name of the application used to create the page. 
 
Scrollbars 
Microsoft Internet Explorer allows web designers to adjust the colors of the scrollbars to make them match 
with the rest of the page content. All you have to do is select the colors you like and WYSIWYG Web Builder 
will add the HTML code for you! 
 



 
 
Page Transitions 
Page transitions allow you to manage the page entry and page exit transitions of your web pages. These 
transitions will only work in Internet Explorer 4 and above. Other browsers are unaffected by these page 
transitions. 
 

 
 
Setup guide borders, rulers and grid 
 
While working on a web page it can be usefull to enable guide border, rulers and grid. 
To change the guide settings select Layout->Guide Settings from the menu. 

 
 

WYSIWYG Web Builder provides a grid to help you align your elements. The grid spacing can be set at any 
size. The grid also has a Snap To feature that you can use to align objects along it automatically when you 



place them close to its lines. 
Guide borders can be useful to make sure all elements on the page stay between specified dimensions. 
Rulers help you arrange elements symmetrically.  
To display the rulers, choose View->Rulers from the menu. 
 
Center in browser 
Most professional web sites are designed so they will look good on different screen sizes. 
Because Web Builder uses absolute positioning for all elements, they can not be stretched over the full width 
and height of a page, since that would 'scramble' the contents of the page. 
 
Here are a few tips for the designing your pages so they are displayed in the center of the browser: 
• Set the Page properties to 800x600  
• Enable the Guide Borders and set them to the same size.  
• Make sure all page contents stays between the guide borders  
• Enable 'Center to browser' in Page Properties 
 
Adding text to a web page 
 
One of the first steps in creating a web page is often adding text. 

 
 
 
 
 
 
 
 

 
Select Insert->Text from the menu and draw a box to indicate the position of the text. Then double click the 
box to start editing the text. Type some text and (press Enter to goto the next line). The box automatically 
changes its size to fit the text. 
 

 
 
 
 
 
 
 
 
 

Next you can change the text attributes by highlighting the text you want to modify with the mouse and then 
choose the new attributes from the Format Toolbar. From the toolbar you can change font type, size, bold, 
italic, underline, text color and highlight color.  
There are lots of other formatting options available from the Format menu: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



To add a link, highlight the text you want to link and select Insert->Hyperlink from the menu. 
To learn more about linking read this topic: 
Linking your pages together (Creating Hyperlinks) 
 
Click anywhere in the page to stop editing. 
 
Adding an image to a web page 
 
Select Insert->Image from the menu and draw a box to indicate the position of the image.  
Or select Image in the toolbox. 
 

 
 
The size of the box doesn’t matter; Web Builder automatically adjusts the box to fit the image after you place 
it. The Image File Open dialog appears so you can locate the image you want to place in the image box. 
Select the image you want to add and click Open to add it to the page. 
 

 
 
To resize the image drag the borders (handles) of the image object. 
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Adding other elements to a web page 
 
Besides text and images WYWISYG Web Builder has tons of other great tools to build your web site. 
Here's a list of the available items: 
 
General Elements 
Text 
Horizontal Line 
Image 
Shape 
Marquee 
Table 
Bookmark 
 
Form Elements 
Form Area 
Push Button 
Checkbox 
Radio button 
Editbox 
Text Area 
Combobox 
File Upload 
Image Button 
Advanced Button 
 
Advanced Elements 
Inline Frame 
HTML 
Active X 
Embedded OLE Object 
Embedded Page 
File Publisher 
Flash 
Java Applets 
Quicktime 
Real Player 
Windows Media Player 
 
Navigation Elements 
Go Menu 
Menu Bar 
Navigation Bar 
 
Extra Elements 
Ad Rotator 
Banner 
Photo Gallery 
Ready to use Java Scripts 
Rollover Image 
 
For more details about these elements and their properties consult the help file of WYSIWYG Web Builder. 
 
Adding custom HTML or Javascript to a web page 
 
Although WYISIWYG Web Builder is NOT an HTML editor, you can insert custom HTML to web page 
generated by Web Builder. 
 
Insert Custom HTML 
The most common way to insert HTML into a web page is by using the HTML object. 
You can use this to add counters, ads, banners or javascripts. 
Select Insert->Advanced->HTML to add the HTML object to your page. Double click the object to edit its 
properties. Now you can enter a description of the HTML (so you can identify the code later) and the HTML 
code. 
 



 
 
Insert Page HTML 
This method should be used if you want to insert HTML in the <HEAD> or <BODY> tags of the page. From 
the menu select Page->Page HTML to display the Page HTML window. 

 
 
In this window the HTML generated by Web Builder is displayed. 
To insert your own code, select the appropriate Tab. Select if the code should be inserted at the Start of 
Page, Between Head tag, Inside Body tag, Beginning of Body, End of body or end of page. 
The custom code will be displayed in the color blue. 
 
Insert Object HTML 
It's also possible to insert custom HTML for a specific element, so you can for example add an extra 
attribute. From the menu select Edit->HTML to display the Object HTML window. 



 
 
Linking your pages together (Creating Hyperlinks) 
 
Hyperlinks are text or images that can be clicked to bring the user to another web file such as a web page, 
images or any other file. They are the essence of the World Wide Web as they link pages within sites and 
web sites to other web sites. To create a hyperlink in Web Builder, follow the intructions below. 
 
Linking text 

 
 
Highlight the text you want to link and select Insert->Link from the menu bar, click the link button on the 
toolbar or press CTRL+K on your keyboard. This will display the Insert Hyperlink window. 
 
Linking an image, shape or rollover image. 
 

 
 



Select the image, shape or rollover image you want to link and select Insert->Link from the menu bar, click 
the link button on the toolbar or press CTRL+K on your keyboard.  
Note that there is also a Link tab in the images properties window. 

 
 
Link to a page on another web site 
Set the Link To option to Web Site. Enter the full URL (Internet Address) of the destination page in the URL 
box. External URLs MUST begin with "http://" or they will not work.  
For example, to link to the Pablo Software Solutions home page, type 
"http://www.pablosoftwaresolutions.com/" instead of "www.pablosoftwaresolutions.com". 
 
Link to a page on your own web site 
Set the Link To option to Internal Web Page. Click 'Select' to choose a page. This will list all pages which are 
part of the current web site project. Select one of the pages and a relative link will automatically be created 
(eg ./products.html). 
 

 
 
Link to a file 
Set the Link To option to Web Site. 
First upload the file to your web site (using a FTP client) and remember the location where you've put it. To 
link to a file so your visitors can download it from your web site, enter the complete URL to the file like this: 
http://www.pablosoftwaresolutions.com/downloads/myfile.zip 
 
Link to an email address 
Select Email Address from the Link To dropdown list. The URL box will automatically be updated with the 
mailto: prefix. Now enter the destination email address like this: 
mailto: webmaster@yourdomain.com 
 



Open the link in a new window 
_blank: opens the link in a new window 
_self: open the link in the current frame 
_parent: open the link in the parent frame 
_top: loads the linked document in the topmost frame 
 
Bookmarks 
Text and images can be set as bookmarks (also called "anchors") that can be linked to within a page. For 
example, if a page has several new items, the news titles for each item can be set as bookmarks and a row 
of links can be added to the top of the page that will each skip down to those bookmarked sections. This 
method of using bookmarks allows visitors to your site to quickly access information by not having to scroll 
down the page to view the information they want. 
 
You can create a Bookmark by using the Bookmark tool from the Insert menu and place it anywhere in the 
page. Make sure you give the bookmark an unique name. Once you have placed the bookmark icon on your 
page, it can be selected from the Bookmark dropdown list. 
 
Saving your web site 
 
To save your web site (including all pages it contains), select File->Save Web Site for the menu and enter a 
name for the project. 
Web Builder uses the extension .wbs (Web Builder Site) to save the project files, to save your page as HTML 
you need to Publish your pages.  
 
Related topic: 
Publishing your web pages
 
Preview a page in your Browser 
 
Select File->Preview (F5) to preview the current page in your browser. 
Depending on the preview scope (Tools->Options->Preview), you can either preview a single page or the 
entire web site. It's also possible to change the browser that is used for previewing. 
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Publishing your web pages 
 
You can publish your web pages using the build-in Publish tool. Select File->Publish to launch the publish 
dialog. 
 

 
 
Publish to a local folder 
Click Add to add a new location to the list. Enter a name for the location a select Local as type. 
Enter the folder where you want to publish the active document. 
Click OK to save the data and then click Publish to save the files to the specified folder. 
 
Publish to a remote FTP server. 
Click Add to add a new location to the list. Enter a name for the location a select Remote as type and enter 
the required fields. If you have a firewall/router select 'Use passive mode for transfers'. 
You can also specify the folder on the FTP server where the files are uploaded. 
Click OK to save the data and then click Publish to save the files to the specified folder. 
 
Pages to Publish 
Select which page or pages you want to publish. 
Entire Web Site, publishes all pages of the web site (except the pages which have enabled 'Don't Publish 
this Page' in Page Properties) 
Select Page Only, publishes the select page, click Select to specify the page to be published. 
Select Page and Sub Pages, publishes the select page and all of its sub pages (if any). 
 
Note: 
If you do not want to copy images or other components along with the HTML file,  
select the Only publish HTML files option. Otherwise all images, activex controls, java applets etc. will be 
copied the same folder. 
 
Adding a Navigation Bar to your web site 
 
One of the exciting features of WYSIWYG Web Builder is the ability to add advanced navigation elements to 
your web page with only a few mouse clicks. The Navigation Bar is one of those elements. 
To insert a Navigation Bar select Insert->Navigation->Navigation Bar. 
A Navigation Bar is a group of buttons, where each button is linked to a different page. 
 

    
 
You can add, edit or remove buttons at any time using the properties. Select Add to insert a new button or 
Edit to modify the properties of an existing button. To remove a button from the Navigation Bar select 
Remove. You can rearrange the button order by using Move Up and Move Down. 
 



 
 
Synchronize with Site Manager 
When this option is enabled, Web Builder automatically synchronizes the Buttons with the content of the Site 
Manager, so you do not have to add all your internal links manually. 
The level parameter specifies which level of the Site Manager will be used to create the buttons.  
First Level: Creates buttons that will link to the children of the root level. 
Parent Level: Creates buttons that will link to all pages in the level above the current page in the Site 
Manager. 
Current Level: Creates buttons that will link to the current page and all other pages that share the same 
parent page. 
Child Level: Create buttons that will link to the children of the current page. 
 
The Navigation Bar can be either Vertical or Horizontal. The Layout Space settings specifies the space 
between 2 buttons. 
 
Navigationbar Style 
To change the style of a Navigation Bar switch to the Style properties. 

 



 
In this window you set things like font type, style, size and color. 
To change the look of the button select one of the button image from the dropdown list. You can select a 
separate image for when the mouse hovers over a navigationbar button. 
 
Web Builder includes a few example styles, but you can easily add your own styles: 
Copy your own button images (gif, jpg or bmp) to this folder 
C:\Program Files\Web Builder\navbar\ 
 
Adding a Menu Bar to your web site 
 
One of the exciting features of WYSIWYG Web Builder is the ability to add advanced navigation elements to 
your web page with only a few mouse clicks. The Menu Bar is one of those elements. 
To insert a Menu Bar select Insert->Navigation->Menu Bar. 
The menubar is a very powerful JavaScript-based menu script that can mimic complex menus found in 
popular GUI applications. Web Builder provides a menubuilder so you can easily add menu items, assign the 
links and set the style for the menu using the style tab.  
 

 
 
Select Add to insert a new item to the menubar or Edit to modify the properties of an existing item. 
To remove an item from the menubar select Remove. 
You can rearrange the items in the menu you can use drag and drop to move the items around or by using 
the Move Up, Move Down, Move Left (<<) or Move Right (>>) buttons. 
The Insert Split button inserts a splitter/divider in the menu. The menubar can be either Vertical or 
Horizontal. 
 
When you enable the option Synchronize with Site Manager, Web Builder automatically synchronizes the 
Buttons with the content of the Site Manager, so you do not have to add all your internal links manually. 
 
Menubar Style 
To change the appearance of the menubar either select a predefined theme of select Default to edit the 
menubar colors and text formating. 
 
Note the effect of the selected theme will only be visible in the browser. So you'll have to preview or publish 
the page first.



Using templates 
 
Web Builder has a very handy feature called 'Templates'. 
Templates can later be used by you (or someone else) to use a basis for a new web site. 
When you save a web page to a template it will include all of the images and other objects in the template 
file. So there is no need to copy these files seperately. So you simply copy one file from one computer to 
another and you can start or continue working on your webpages. Web Builder Templates have the .wbt 
extension and are saved in the sub folder \Templates of the Web Builder folder. 
 
Create a web site based on a template 
Select File->New Web Site From Template to display the template selection window. 
 

 
 
Choose a template and click OK. The Save Web Site As window will now ask you to specify a name for the 
web site. Enter the name and click Save to create the new web site based on the select template. 

 
 
To save your own web site as template select: File->Save As Template from the menu. 
 
Addtional templates can be downloaded here: Templates

http://www.wysiwygwebbuilder.com/templates.html


Importing an existing HTML page in to Web Builder 
 
Although Web Builder is NOT an HTML editor, you can import existing HTML pages. 
Select Page->Import->Import HTML Page from the menu to display the Import HTML page window. 
 

 
 
You can either select an HTML page from your local drive or specify a URL of an online website. 
Click OK to start importing the page. Web Builder will automatically copy all images to your local drive (as 
specified in the Folders page of the Web Builder configuration). 
 
Notes about importing HTML: 
• WYSIWYG Web Builder is not an HTML editor, but an HTML generator! Web Builder imports the HTML by 
rendering the contents of an existing page and then attempts to convert the layout to Web Builder's internal 
object format. 
 
• The import feature currently only imports text, images, form elements and body attributes (link colors, 
background images, meta tags). Tables, scripts, stylesheets and multimedia components are not imported. 
But in most cases this is good enough to get you started. 
 
• Web Builder does not parse style sheets, so is some cases the text may look different than the original 
page.  
 
• Web Builder currently doesn't support framesets. If you want to import a web page that's using frames you'll 
have to import all individual pages separately. 
 
• It is very difficult to support all different types of HTML. Even the populair browsers will interpret HTML 
differently, so don't expect miracles. If a page fails to be imported it probably contains code that Web Builder 
doesn't understand and you still have to start from scratch. 
 
• Importing web pages created with WYSIWYG Web Builder will give the best results! 
 
 
Creating Forms 
 
A form provides a way you to collect information from the people who view your web pages.  
A viewer enters data or makes choices among several options and then submits the form.  
The results can be sent to you by email. If your web server has the right software, you can save the form 
results in a database. 
 
How do I create a form in WYSIWYG Web Builder? 
Drag the Form Area from the toolbox to the page. 

 
 
 
 
 
 
 
 
 
 
 
 

Design your form by adding some Form controls to the form. Web Builder includes a wide range of form 
controls like:·buttons, checkboxes, radio buttons, editbox etc. 
You can also make text and images part of the form. 



 
Now let's create a simple feedback form. 

 
The text items (Name, Rate my site, Poor, Good and Excellent) are just regular text elements. See also: 
Adding text to a web page. 
 
Insert an Editbox and open its properties. Change the Name property to: Name. 
Insert a Button, open its properties and set the Button Type to :Submit and change the Value to: 
Submit my feedback. 
Insert 3 radio buttons. Set the Group Name of all those radio buttons to: Rating. 
Next set their values to poor, good and excellent. 
 
And the last step is to setup the properties of the form.  
 

 
Form Name: Feedback Form    Action: mailto:your.email@email.com 
Method: POST                            Encoding Type: text/plain 
 
This is what the Form will looks like in your browser: 
 
 

 
 
Depending on the system settings it's possible that this form will not work on all computers. The mailto: 
action as specified in the Form Properties is not the most reliable way to collect data in a form. See also: 
http://www.wysiwygwebbuilder.com/forum/viewtopic.php?t=135 
This topic includes a workaround for this problem using PHP. 
 

http://www.wysiwygwebbuilder.com/add_text.html
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Create an Inline Frame 
 
You can create a floating frame, also called an inline frame, that appears within the content of a Web page. 
You can either display a page from your own web site or refer to an external URL. 
 
Example: 

 
 
Select Insert->Advanced->Inline Frame from the menu and draw a box to indicate the position of the inline 
frame. You can also select Inline Frame in the toolbox. 
Double click the object to display the Inline Frame Properties. 
 

 
 
Name 
Used to set a name for the inline frame.  Link to Web Site: display a page from an external web site. 
Syntax: http://www.google.com 
Internal Web Page 
Display one of the pages of your web site. Click 'Select' to choose a page. The Select Page window will 
show all the pages which are part of the current web site project. Web Builder will automatically create to 
correct (relative) URL when you publish your pages. 
Show border 
Used to specify the whether to have a border for the inline frame or not.  
Scrollbars 
Used to specify whether the inline frame should have scrolling capability or not. Possible values: If Needed, 
Never or Always. 
Alternate textThis text will be displayed by browsers which do not support inline frames. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Control the contents of an inline frame using links 
It's very easy to control the contents of an inline frame using the target properties of a link. 
The most important thing to make this work is to set the name property of the inline frame object. 
In the example above we have set the name to frame2, then we opened the properties of a link and set the 
Target field to frame2.   Click this link display http://www.google.com
 
Of course you can also use the navigationbar buttons to control the contents of the inline frame using the 
same method. 
 

    
 
Related topics: 
How can I use Inline Frames to implement a masterborder? 
How do I create a transparent inline frame?
 
Change the color or style of a hyperlink 
 
By default all hyperlinks in your web page have underlines and use the default HTML link colors (link:blue, 
visited:purple, active: red, hover:blue). WYSIWYG Web Builder gives you the option to customize the way 
hyperlinks will be displayed in the browser by introducing the Hyperlink Style Sheet Editor. This way it is 
possible to remove the underline from a link or make it another color. 
 
Select Format->Hyperlink Style Sheet from the menubar to display the Hyperlink Style Sheet Editor. 
 

 
 
Click Add to add a new hyperlink style. You must give the style a name like 'black_hyperlink' or 
'no_underline'. 
 
A hyperlink has four states: 
• Linked 
• Visited 
• Active 
• Hover 
 

 
 
You can customize the formatting of the hyperlink by clicking on one of the states.  
To remove the underline from a link simply uncheck the box 'Underline' . 
 
 

http://www.google.com/
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Apply the style to a link 
Now that you've created a hyperlink style you can apply it to a text link. 
 

 
 
Highlight the text you want to link and select Insert->Link from the menu bar, click the link button on the 
toolbar or press CTRL+K on your keyboard. This will display the Insert Hyperlink window. 
 

 
 
Change the Style from the dropdown list to 'black_hyperlink'. 
Publish or preview the page to view the effect.  Note that Web Builder will always show links in underlined 
blue. 
 
How to use Embedded Pages 
 
The Embedded Page object is a very cool feature which allows you to re-use objects from another page 
(from your web site) in the current web page. 
Let's say you have a certain layout which is the same for all your pages and you don't want this copy/paste it 
between all your pages; then simply create the layout once in page and insert the layout of that page in all 
your other pages using the embedded page object. When you want to update the layout you will only have to 
do this once in the orginal page. 
 
Here's an example: 
1. Create a new website, Web Builder automatically add the first page called 'index'. 
2. Insert a new page usin gthe Site Manager and rename it to 'master_page' 
 



 
 
3. Now let's add a navigationbar to the master_page. Insert->Navigation->Navigationbar. 
 

 
 
4. Switch back to the index page (click on the index tab) and insert an Embedded Page object. 
 

 
 
5. Double click the object you've just inserted to select a page. Next click the Select-button to display the 
Select Page window and choose master_page from the list. Click OK to return to the page. 
 

 
 
You will notice that the navigationbar of your master_page now has become a part of the index page. If you 
go back to the master page and you modified something in that page, it automatically is updated in the index 
page as well. Of course this feature is not limited to navigationbars only, you can add any element to the 
master_page. 
 
Notes: 
Place all objects on the master page aligned to the left and top border, so you do not have any margins. 
If you use the master_page only for embedded purposes and not as standalone page, you can enable 'Don't 
Publish this page' in Page Properties, so the page won't be published when the entire website is published. 
 
In contrast to inline frames, when using the Embedded Page object, all objects from that page are merged in 
the current page as if they are really a part of the page. You must however edit them in the master page. 
 
Related topic:  Create an Inline Frame

http://www.wysiwygwebbuilder.com/iframe.html


What's Next? 
 
This online tutorial is just a small extract from the help file. For more details read the help file, which includes 
information about all options and elements found in WYSIWYG Web Builder. 
 
Another great resource of information is the online forum: 
http://www.wysiwygwebbuilder.com/forum 
 
Make sure you also read the Frequently Asked Questions (FAQ) section: 
http://www.wysiwygwebbuilder.com/forum/viewforum.php?f=10
 
 
 
 
 
 

http://www.wysiwygwebbuilder.com/forum
http://www.wysiwygwebbuilder.com/forum/viewforum.php?f=10

